Zyxel GS1900-24HP Managed Gigabit Ethernet (10/100/1000) 1U Black – photo 1
Zyxel GS1900-24HP Managed Gigabit Ethernet (10/100/1000) 1U Black – photo 2
Zyxel GS1900-24HP Managed Gigabit Ethernet (10/100/1000) 1U Black – photo 3
Zyxel GS1900-24HP Managed Gigabit Ethernet (10/100/1000) 1U Black – photo 4
Out of Stock / Please Enquire ETA
ZYXEL

Zyxel GS1900-24HP Managed Gigabit Ethernet (10/100/1000) 1U Black

R6,127
incl. VAT: R7,046
  • Stock: Out of Stock / Please Enquire ETA
  • Brand: ZYXEL
  • Model: GS190024HPV2-EU0101F
  • Weight: 1 kg
  • Dimensions: 27 × 44 × 4 cm
  • EAN: 4718937609505
  • Product code: 842373
Please Inquire
R6,127 incl. VAT: R7,046
We will email you when the product is back in stock.
SavePDF

Key features

  • Managed SNMP v1,v2,v3, RMON (1,2,3,9)
  • Quality of Service (QoS) support
  • Basic switching RJ-45 Ethernet ports quantity: 24
  • 10BASE-T, 100BASE-T, 1000BASE-T
  • 1U
  • Power supply included

Description

Simple, Fast and Smart Managed Switches for Small Business Connectivity

The ZyXEL GS1900 Series of 8/16/24/48-port GbE Smart Managed Switch with Gigabit speed and essential managing functions bring your business network more fexibility and connectivity. The 1900 Series consists of eight (8) models—the GS1900-8, GS1900-8HP, GS1900-16, GS1900-24E, GS1900-24, GS1900-24HP, GS1900-48 and GS1900-48HP. Providing GbE switches with powersaving functions, fanless design and full IPv6 support ensure your network to be ready for future expansions. In addition, the PoE models GS1900-8HP/24HP/48HP Gigabit switch complies with the IEEE 802.3at Power over Ethernet (PoE) Plus standard.

Versatility and fexibility for different needs

The complete ZyXEL GS1900 Series has an essential portfolio of 8/16/24/48-port compact desktop and rackmount size with GbE connectivity. All models support multiple deployment methods to fulfill the needs for small offices and meeting room environments such as wall-, under table- or desktop-mounting and rackmount options. It’s now quick and effortless to enjoy the high-speed business network applications without a hitch. Additionally, the GS1900-24/24HP/48/48HP is equipped with 2 extra SFP slots to provide 100M and GbE speeds for long-distance deployments.

Simple, intuitive wizard set up

For small businesses that want to manage their infrastructure in advance, the ZyXEL GS1900 Series comes with a friendly built-in Web-based browser for simple configuration and management. Moreover, the friendly step-by-step intuitive wizard helps avoiding multiple complicated configuration pages for quick set up with few clicks in the matter of minutes. To guide the users from start-up, VLAN, Guest VLAN to QoS setting, the ZyXEL Series offers four most common steps and combines them into a quick and easy setup wizard; which does not just save deployment time and efforts, but is also helpful especially for the non-IT staff.

Avoiding network errors with easy management

The ZyXEL GS1900 Series is equipped with advanced management features to make the network stable and secure: loop protection that prevents network flooding, dual images to provide a backup FW if one crashes and storm control to ensure network efficiency, friendly on/off DoS with simple click to enable/disable instead of several setup pages, while SSL ensures the management frames are well encrypted when the device is accessed. The GS1900 Series provides network error prevention features and integrated network security for reduced risk and improved data streaming.

Energy saving for IEEE 802.3az

As operating overheads such as electric bills increase constantly due to the arising green awareness, businesses have to avoid unnecessary energy waste. The built-in IEEE 802.3az Energy Efficient Ethernet (EEE) and more ZyXEL innovative green features of ZyXEL GS1900 Series can reduce energy consumption of Ethernet devices through multiple intelligent ways.

Specifications

Management features
Switch type Managed
Quality of Service (QoS) support Yes
MIB support RFC 1213 MIB II, RFC 2819, RFC 1215, RFC 1493
Ports & interfaces
Basic switching RJ-45 Ethernet ports quantity 24
Basic switching RJ-45 Ethernet ports type Gigabit Ethernet (10/100/1000)
Gigabit Ethernet (copper) ports quantity 24
SFP module slots quantity 2
Network
Networking standards IEEE 802.1p, IEEE 802.3, IEEE 802.3ab, IEEE 802.3af, IEEE 802.3at, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x
Copper ethernet cabling technology 10BASE-T, 100BASE-T, 1000BASE-T
Flow control support Yes
Broadcast storm control Yes
Rate limiting Yes
Security
Security algorithms 802.1x RADIUS
MAC address filtering Yes
SSH/SSL support Yes
Protocols
Management protocols SNMP v1,v2,v3, RMON (1,2,3,9)
Design
Form factor 1U
Product colour Black
Power
Power supply included Yes
Certificates
Certification CE, FCC, C-Tick, Class A (GS1900-8HP/24/24HP/48/48HP) CE, FCC, C-Tick, Class B (GS1900-8/16/24E) BSMI CNS13438
Logistics data
Harmonized System (HS) code 85176990
HPE Aruba Instant on 1930 24G 4SFPSFP Switch 28-port Gigabit
✅ In Stock
Brand: HP ENTERPRISE
R6,125
incl. VAT:R7,044
Add to Cart
TP-Link Omada 24-Port Gigabit L2+ Managed Switch with 4 10GE SFP+ Slots
✅ In Stock
Brand: TP-LINK
TP-Link | Omada L2+ managed switches provide high performance, powerful L2 and L2+ features like static routing, enterprise-level QoS, advanced securi..
R6,125
incl. VAT:R7,044
Add to Cart
NETGEAR GS728TX L2/L3 10G Ethernet (100/1000/10000) Black
✅ In Stock
Brand: NETGEAR
NETGEAR provides complimentary technical support for NETGEAR products for 90 days from the original date of purchase.NETGEAR ProSupport for HomeAll-In..
R6,121
incl. VAT:R7,039
Add to Cart
NETGEAR MS108UP Unmanaged 2.5G Ethernet (100/1000/2500) Power over Ethernet (PoE)
✅ In Stock
Brand: NETGEAR
NETGEAR brings the first UnmanagedMulti-Gigabit PoE++ switch MS108UP with 60Watts per port Ultra60 PoE++ technology, ideal for powerful PoE++ installa..
R6,143
incl. VAT:R7,065
Add to Cart
TP-Link Omada 28-Port Gigabit Smart Switch with 16-Port PoE+
✅ In Stock
Brand: TP-LINK
- 24× Gigabit Ports (16× PoE+), 4× Gigabit SFP Slots- 150 W Total PoE Budget- Fanless Design for Silent Operation- Zero-Touch Provisioning- Centralize..
R6,149
incl. VAT:R7,071
Add to Cart
TP-Link Omada 18-Port Gigabit Smart Switch with 16-Port PoE+
✅ In Stock
Brand: TP-LINK
TP-Link’s brand new Omada smart switches provide huge upgrade comparing with previous versions. Theswitches can be managed by Omada SDN Controller, wh..
R6,177
incl. VAT:R7,103
Add to Cart
Grandstream GWN7812P Switch Enterprise Managed L3 Managed 16 X 10/100/1000 (PoE) Grandstream GWN7812P Switch Enterprise Managed L3 Managed 16 X 10/100/1000 (PoE)
✅ In Stock
R6,197
incl. VAT:R7,126
Add to Cart
TP-Link Omada 24-Port Gigabit L2+ Managed Switch with 4 10GE SFP+ Slots
✅ In Stock
Brand: TP-LINK
TP-Link | Omada L2+ managed switches provide high performance, powerful L2 and L2+ features like static routing, enterprise-level QoS, advanced securi..
R6,054
incl. VAT:R6,962
Add to Cart