Zyxel GS1900-24EP Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black – photo 1
Zyxel GS1900-24EP Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black – photo 2
Zyxel GS1900-24EP Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black – photo 3
Zyxel GS1900-24EP Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black – photo 4
Zyxel GS1900-24EP Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black – photo 5
✅ In Stock
ZYXEL

Zyxel GS1900-24EP Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black

R6,530
incl. VAT: R7,509
  • Stock: Backordered - delivers in 10-15 days
  • Brand: ZYXEL
  • Model: GS1900-24EP-EU0101F
  • Weight: 1 kg
  • Dimensions: 10 × 10 × 10 cm
  • EAN: 4718937609468
  • Product code: 461061
Backordered goods Delivery in 10–15 working days

Available Options

R6,530 incl. VAT: R7,509
SavePDF

Key features

  • Start up button
  • VLAN
  • QoS
  • Link aggregation

Description

Near silent operation

The GS1900 Series includes both fan-less and built-in smart fan models. The smart fan is designed to automatically adjust speed based on device temperature. You can barely hear the sound while the switch is operating. It is ideal for your office environment.

Intelligent PoE+ powers more devices

PoE models (8HP/10HP/24EP/24HPv2/48HPv2) come with default PoE consumption mode which delivers only the actual power required by your networked devices, reserves the rest and optimizes its power budget. That means a single switch can power more APs, IP cameras and VoIP phones, ensuring a better ROI for your business. All of them support the IEEE 802.3at providing a maximum of 30W per port.

Speedy Gigabit performance—built for SMBs

The GS1900 is a series of switches with full non-blocking bandwidth of up to 1 Gbps per port. An ideal upgrade from an unmanaged switch, it’s a great choice for SMBs that want to enjoy high-speed business network applications at full wired non-blocking speed.

Easy and intuitive management

The Smart Managed GS1900 Series switch feature with web-based interface to manage advanced functions such as VLAN, QoS, IGMP Snooping, Link Aggregation (LAG), IPv6 and DoS prevention easily. Also, the user-friendly wizard helps to walk through setup, configuration and even advanced settings quickly.

Specifications

Management features
Switch type Managed
Switch layer L2
Quality of Service (QoS) support Yes
MIB support RFC 1213 MIB II RFC 2819 RMON (group 1, 2, 3, 9) RFC 1215 generic traps RFC 1493 bridge Zyxel private common MIB
Ports & interfaces
Basic switching RJ-45 Ethernet ports quantity 24
Basic switching RJ-45 Ethernet ports type Gigabit Ethernet (10/100/1000)
Installed SFP modules quantity 0
Installed SFP+ modules quantity 0
Power connector AC-in jack
Network
Networking standards IEEE 802.1D, IEEE 802.1ab, IEEE 802.1af, IEEE 802.1s, IEEE 802.1w, IEEE 802.3at, IEEE 802.3az, IEEE 802.3p, IEEE 802.3u, IEEE 802.3x
10G support No
Cable types supported Cat5, Cat5e
Port mirroring Yes
Full duplex Yes
Flow control support Yes
Link aggregation Yes
Auto MDI/MDI-X Yes
Spanning tree protocol No
Ethernet LAN data rates 10,100,1000 Mbit/s
MAC address auto-learning supported Yes
VLAN support Yes
Virtual LAN features Tagged VLAN, VLAN Identifier ( VLAN ID), Voice VLAN
Data transmission
MAC address table 8000 entries
Switching capacity 48 Gbit/s
Forwarding rate 35.7 Mpps
Store-and-forward Yes
Jumbo frames support Yes
Jumbo frames 9000
Packet buffer memory 0.525 MB
Security
DHCP features DHCP client
IGMP snooping Yes
Security algorithms 802.1x RADIUS
MAC address filtering Yes
Static port security Yes
SSH/SSL support Yes
Password protection Yes
Authentication type HWTACACS+, IEEE 802.1x, RADIUS
Multicast features
Multicast support Yes
Design
Rack mounting Yes
Stackable Yes
Product colour Black
Reset button Yes
Performance
Noise level 26 dB
Power
Power supply included Yes
AC input voltage 100 - 240 V
AC input frequency 50 - 60 Hz
Power consumption (typical) 206.5 W
Power over Ethernet (PoE)
Power over Ethernet (PoE) Yes
Weight & dimensions
Width 330 mm
Depth 330 mm
Height 44 mm
Weight 2.48 kg
Packaging content
Cables included AC
Quick start guide Yes
User guide Yes
Manual Yes
Packaging data
Package type Box
Logistics data
Harmonized System (HS) code 85176990
TP-Link Omada 8-Port 10GE SFP+ L2+ Managed Switch
✅ In Stock
Brand: TP-LINK
TP-Link | Omada L2+ managed switches provide high performance, powerful L2 and L2+ features like static routing, enterprise-level QoS, advanced securi..
R6,530
incl. VAT:R7,509
Add to Cart
TP-Link Omada SL2428P network switch Managed L2 Fast Ethernet (10/100) Power over Ethernet (PoE) 1U Black
✅ In Stock
Brand: TP-LINK
TP-Link’s brand new Omada smart switches provide huge upgrade comparing with previous versions. The switches can be managed by Omada SDN Controller, w..
R6,535
incl. VAT:R7,515
Add to Cart
Switch UBIQUITI Switch Flex XG Type L2 USW-FLEX-XG Switch UBIQUITI Switch Flex XG Type L2 USW-FLEX-XG
✅ In Stock
Brand: UBIQUITI
The Switch Flex XG (USW Flex XG) is a fully managed, mult-gigabit, Layer 2 switch with (4) 10GbE RJ45 ports and (1) GbE PoE input. The USW Flex XG spo..
R6,545
incl. VAT:R7,526
Add to Cart
Digitus Switch 8 Port Gigabit PoE L2 Managed 4 SFP Uplink
✅ In Stock
Brand: DIGITUS
R6,554
incl. VAT:R7,537
Add to Cart
HPE ARUBA INSTANT on 1930 24G 4SFP/SFP+ Switch
✅ In Stock
Brand: HP ENTERPRISE
R6,554
incl. VAT:R7,537
Add to Cart
TP-Link Omada 28-Port Gigabit Smart Switch with 16-Port PoE+
✅ In Stock
Brand: TP-LINK
- 24× Gigabit Ports (16× PoE+), 4× Gigabit SFP Slots- 150 W Total PoE Budget- Fanless Design for Silent Operation- Zero-Touch Provisioning- Centralize..
R6,499
incl. VAT:R7,474
Add to Cart
TP-Link TL-SG1048 network switch Unmanaged Gigabit Ethernet (10/100/1000) 1U Black
✅ In Stock
Brand: TP-LINK
What This Product DoesThe 48-Port Gigabit Switch TL-SG1048 is designed to meet the needs of the most demanding workgroup and departmental connectivity..
R6,572
incl. VAT:R7,557
Add to Cart
D-Link 24-Port Desktop Gigabit Unmanaged PoE Switch with 2 x 100/1000Mbps Combo Ports
✅ In Stock
Brand: D-LINK
26 Port Gigabit Max PoE SwitchDGS-1026MPThe D-Link DGS-1026MP 26-Port Gigabit Max PoE Switch enables users to easily connect and power PoE-capable dev..
R6,577
incl. VAT:R7,564
Add to Cart