Zyxel GS1900-10HP Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black – photo 1
Zyxel GS1900-10HP Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black – photo 2
Zyxel GS1900-10HP Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black – photo 3
Zyxel GS1900-10HP Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black – photo 4
✅ In Stock
ZYXEL

Zyxel GS1900-10HP Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black

R3,587
incl. VAT: R4,125
  • Stock: Backordered - delivers in 10-15 days
  • Brand: ZYXEL
  • Model: GS1900-10HP-EU0102F
  • Weight: 1 kg
  • Dimensions: 10 × 10 × 10 cm
  • EAN: 4718937621200
  • Product code: 461059
Backordered goods Delivery in 10–15 working days

Available Options

R3,587 incl. VAT: R4,125
SavePDF

Key features

  • Managed L2 Web-based management SNMP, RMON, ICMP, Syslog
  • Quality of Service (QoS) support
  • Basic switching RJ-45 Ethernet ports quantity: 8 Console port: RJ-45
  • 10BASE-T, 100BASE-T, 1000BASE-T
  • MAC address table: 8000 entries Switching capacity: 20 Gbit/s
  • AC Power supply included Power over Ethernet (PoE)

Description

Near silent operation

The GS1900 Series includes both fan-less and built-in smart fan models. The smart fan is designed to automatically adjust speed based on device temperature. You can barely hear the sound while the switch is operating. It is ideal for your office environment.

Intelligent PoE+ powers more devices

PoE models (8HP/10HP/24EP/24HPv2/48HPv2) come with default PoE consumption mode which delivers only the actual power required by your networked devices, reserves the rest and optimizes its power budget. That means a single switch can power more APs, IP cameras and VoIP phones, ensuring a better ROI for your business. All of them support the IEEE 802.3at providing a maximum of 30W per port.

Speedy Gigabit performance—built for SMBs

The GS1900 is a series of switches with full non-blocking bandwidth of up to 1 Gbps per port. An ideal upgrade from an unmanaged switch, it’s a great choice for SMBs that want to enjoy high-speed business network applications at full wired non-blocking speed.

Specifications

Management features
Switch type Managed
Switch layer L2
Quality of Service (QoS) support Yes
Web-based management Yes
System event log Yes
MIB support RFC 1213 MIB II, RFC 2819 RMON (group 1, 2, 3, 9), RFC 1215 generic traps, RFC 1493 bridge
Ports & interfaces
Basic switching RJ-45 Ethernet ports quantity 8
Basic switching RJ-45 Ethernet ports type Gigabit Ethernet (10/100/1000)
SFP module slots quantity 2
Console port RJ-45
Network
Networking standards IEEE 802.1D, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.3, IEEE 802.3ab, IEEE 802.3at, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x
10G support No
Copper ethernet cabling technology 10BASE-T, 100BASE-T, 1000BASE-T
VLAN support Yes
Virtual LAN features Voice VLAN
Data transmission
MAC address table 8000 entries
Switching capacity 20 Gbit/s
Throughput 14.88 Mpps
Jumbo frames 9000
Security
DHCP features DHCP client
IGMP snooping Yes
Security algorithms 802.1x RADIUS, SSL/TLS
MAC address filtering Yes
Protocols
Management protocols SNMP, RMON, ICMP, Syslog
Design
Rack mounting No
Product colour Black
LED indicators Yes
Wall mountable Yes
Performance
Mean time between failures (MTBF) 800259 h
Power
Power source AC
Power supply included Yes
AC input voltage 100 - 240 V
AC input frequency 50 - 60 Hz
Power consumption (max) 95.3 W
Power over Ethernet (PoE)
Power over Ethernet (PoE) Yes
Power over Ethernet (PoE) ports quantity 8
Total Power over Ethernet (PoE) budget 77 W
Operational conditions
Operating temperature (T-T) 0 - 40 °C
Storage temperature (T-T) -40 - 70 °C
Operating relative humidity (H-H) 10 - 95%
Storage relative humidity (H-H) 10 - 95%
Weight & dimensions
Width 250 mm
Depth 104 mm
Height 27 mm
Weight 720 g
Packaging content
Cables included AC
Certificates
Certification CE, FCC, RCM, Class A, BSMI CNS 13438, LVD EN 62368-1, BSMI CNS 14336-1
ALLNET Switch Smart Managed 6 Port Gigabit 95W 4x PoE 1x Gi 6 ALLNET Switch Smart Managed 6 Port Gigabit 95W 4x PoE 1x Gi 6
✅ In Stock
Brand: ALLNET
R3,587
incl. VAT:R4,125
Add to Cart
ALLNET ALL-SG8420M Managed L2 Gigabit Ethernet 10-100-1000 Full Duplex Rack Mount 19U ALLNET ALL-SG8420M Managed L2 Gigabit Ethernet 10-100-1000 Full Duplex Rack Mount 19U
✅ In Stock
Brand: ALLNET
R3,587
incl. VAT:R4,125
Add to Cart
DIGITUS 24-port Gigabit Switch 19-inch Unmanaged DIGITUS 24-port Gigabit Switch 19-inch Unmanaged
✅ In Stock
Brand: DIGITUS
R3,587
incl. VAT:R4,125
Add to Cart
TP-Link SG2206MP network switch L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE)
✅ In Stock
Brand: TP-LINK
Multiple Application ScenariosWi-Fi CoverageWorks with Access PointsSurveillanceWorks with IP CamerasConference CallWorks with IP PhonesWired Connecti..
R3,587
incl. VAT:R4,125
Add to Cart
NETGEAR GS110TP Managed L2/L3/L4 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Grey
✅ In Stock
Brand: NETGEAR
The NETGEAR GS110TPv3 8-Port Gigabit PoE+ Ethernet Smart Managed Pro Switch comes with 8 PoE copper ports and 2 dedicated SFP ports for fiber uplinks...
R3,586
incl. VAT:R4,124
Add to Cart
Dahua Technology SG4020LP network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black Dahua Technology SG4020LP network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black
✅ In Stock
Brand: DAHUA
SG4020LP20-Port Cloud Managed Desktop Gigabit Switch with 16-Port PoE..
R3,592
incl. VAT:R4,130
Add to Cart
Dahua Technology DH-CS4226-24ET-375 network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black Dahua Technology DH-CS4226-24ET-375 network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black
✅ In Stock
Brand: DAHUA
Highly intuitive, the Smart Managed Switch can manage local networks. With the DoLynk Care platform, it can also perform cloud management. The switch ..
R3,598
incl. VAT:R4,138
Add to Cart
ARUBA ION 1930 8G 2SFP SW STOCK - .
✅ In Stock
Brand: HPE
R3,575
incl. VAT:R4,111
Add to Cart