Zyxel GS1920-24V2 network switch Managed Gigabit Ethernet (10/100/1000) Black – photo 1
Out of Stock / Please Enquire ETA
ZYXEL

Zyxel GS1920-24V2 network switch Managed Gigabit Ethernet (10/100/1000) Black

R3,938
incl. VAT: R4,529
  • Stock: Out of Stock / Please Enquire ETA
  • Brand: ZYXEL
  • Model: GS1920-24V2-EU0101F
  • EAN: 760559125561
  • Product code: 973855
Please Inquire
R3,938 incl. VAT: R4,529
We will email you when the product is back in stock.
SavePDF

Key features

  • NebulaFlex™ gives you the flexibility to switch between standalone and our license-free Nebula cloud management
  • Nebula cloud management allows easy deployment real-time configurations and effortless access to all your cloud devices anytime
  • Using user-friendly web-based GUI to manage and set up the switch without learning complex CLI
  • Smart fan and fanless designs offer silent operations in your office
  • Check real-time status intuitively by cloud and PoE LED indicators

Description

The GS1920v2 series extends the success of the best-selling GS1920 series with a stylish new look and enables cloud manageability with Zyxel NebulaFlexTM technology.

What’s new?

The GS1920v2 series comes with a fresh, modern look, a more intuitive user experience, and a new member—the 8HP model.

Manage it your way!

The GS1920v2 series introduces Zyxel NebulaFlexTM, which allows you to easily switch between standalone mode and our license-free Nebula cloud management platform anytime with just a few simple clicks.

Maximum flexibility for your Gig

The GS1920v2 series is ideal for SMB deployment in multiple scenarios, with its unique port combinations futureproofing your network to ensure easy growth down the road.

Whisper-quiet operation

Smart fan and fanless designs for silent operation in your workplace.

User-friendly LED indicators

View real-time status instantly with cloud and PoE power-usage LED indicators.

Power more devices more easily

Provides 30W per port and a wide range of power budget options from 130W to 375W—ideal for denser PoE deployments.
Default consumption mode boosts efficiency by delivering the actual power required.

Zyxel ONE Network

Use the complimentary ZON Utility to configure and discover switches, WLANs, and gateways in your network with one click.

Designed for the long haul

A web smart managed switch with an enterprise-grade hardware design. Built-in state-of-the-art hardware technology brings high quality and robustness to SMB networks.

Specifications

Management features
Switch type Managed
Quality of Service (QoS) support Yes
ARP inspection Yes
System event log Yes
MIB support RFC 1066, RFC 1213, RFC 1157, RFC 1493, RFC 1643, RFC 1757, RFC 2011.2012,2013, RFC 2233, RFC 2358, RFC 2674, RFC 2819,2925, RFC 3621, RFC 4022, RFC 4113, RFC 4292, RFC 4293
Ports & interfaces
Basic switching RJ-45 Ethernet ports quantity 24
Basic switching RJ-45 Ethernet ports type Gigabit Ethernet (10/100/1000)
Installed SFP modules quantity 0
Installed SFP+ modules quantity 0
Combo SFP ports quantity 4
Fiber optic connector SFP
Network
Networking standards IEEE 802.1D, IEEE 802.1Q, IEEE 802.1ab, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z
10G support No
Copper ethernet cabling technology 100BASE-TX, 1000BASE-T
Flow control support Yes
Rate limiting Yes
Spanning tree protocol Yes
VLAN support Yes
Virtual LAN features Private VLAN, Voice VLAN, Protocol-based VLAN, MAC address-based VLAN, Port-based VLAN, IP subnet–based VLAN
Optical fiber
Fiber ethernet cabling technology 1000BASE-X
Data transmission
MAC address table 16000 entries
Switching capacity 56 Gbit/s
Forwarding rate 42 Mpps
Packet buffer memory 1.5 MB
Security
DHCP features DHCP snooping, DHCP relay, DHCPv6 relay, DHCP client
Access Control List (ACL) Yes
IGMP snooping Yes
Security algorithms 802.1x RADIUS, SNMP, SNMPv3
MAC address filtering Yes
IP-MAC-Port binding Yes
Authentication Guest VLAN, Port-based authentication
Password protection Yes
Authentication type IEEE 802.1x, RADIUS
CPU defense Yes
Queue scheduling algorithms SPQ, WFQ, Weighted Round Robin (WRR)
Multicast features
Multicast support Yes
Design
Rack mounting Yes
Product colour Black
LED indicators Yes
Safety LVD, BSMI
Electromagnetic compatibility FCC 15 A, CE A, BSMI EMC
Performance
Internal memory 256 MB
Flash memory 32 MB
Noise level 0 dB
Mean time between failures (MTBF) 911301 h
Power
AC input voltage 100 - 240 V
AC input frequency 50 - 60 Hz
Power consumption (max) 22.5 W
Power over Ethernet (PoE)
Power over Ethernet (PoE) No
Operational conditions
Operating temperature (T-T) 0 - 50 °C
Storage temperature (T-T) -40 - 70 °C
Operating relative humidity (H-H) 10 - 95%
Storage relative humidity (H-H) 10 - 95%
Heat dissipation 76.73 BTU/h
Weight & dimensions
Width 441 mm
Depth 131 mm
Height 44 mm
Weight 2.1 kg
Packaging content
Cables included AC
Rack mount kit Yes
Packaging data
Package width 558 mm
Package depth 214 mm
Package height 79 mm
Package weight 2.91 kg
Certificates
Certification RoHS
Logistics data
Harmonized System (HS) code 85176990
TP-Link Omada IES208G network switch Managed Gigabit Ethernet (10/100/1000) TP-Link Omada IES208G network switch Managed Gigabit Ethernet (10/100/1000)
✅ In Stock
Brand: TP-LINK
Enhanced Networking Stability and Security1+1 Redundant Power InputEquipped with dual power input ports and a wide 9.6-60V DC voltage range, ensuring ..
R3,932
incl. VAT:R4,522
Add to Cart
Switch MIKROTIK CRS326-24G-2S+IN Switch type Managed 24xRJ-45 ports RJ-45 Ports Type Gigabit Ethernet (10/100/1000) 2xSFP+ module slots quantity 10G support Yes Power over Ethernet (PoE) Yes CRS326-24G-2S+IN Switch MIKROTIK CRS326-24G-2S+IN Switch type Managed 24xRJ-45 ports RJ-45 Ports Type Gigabit Ethernet (10/100/1000) 2xSFP+ module slots quantity 10G support Yes Power over Ethernet (PoE) Yes CRS326-24G-2S+IN
✅ In Stock
Brand: MIKROTIK
A home network setup doesn’t have to be a compromise. This compact and quiet switch is packing some serious server room grade features: a pair of 10G ..
R3,930
incl. VAT:R4,519
Add to Cart
TP-Link Festa FS318G Managed Gigabit Ethernet (10/100/1000) White
✅ In Stock
Brand: TP-LINK
Festa 一 A Networking Solution Built For Small Business, No IT RequiredFesta offers business-class features with consumer-inspired simplicity. Our free..
R3,927
incl. VAT:R4,516
Add to Cart
Planet IGS-801T 8-Port Industrial Gigabit Ethernet Switch
✅ In Stock
Brand: PLANET
R3,927
incl. VAT:R4,516
Add to Cart
TP-Link Festa FS328G L2/L2+ Gigabit Ethernet (10/100/1000) White
✅ In Stock
Brand: TP-LINK
An Easy-to-Use SmartManaged Switch,No IT RequiredFesta 一 A Networking Solution Built For Small Business, No IT RequiredFesta offers business-class fea..
R3,951
incl. VAT:R4,544
Add to Cart
TP-Link JetStream 8-Port Gigabit Smart PoE+ Switch with 2 SFP Slots
✅ In Stock
Brand: TP-LINK
What This Product DoesTP-LINK Gigabit Smart Switch TL-SG2210P is equipped with 8 gigabit RJ45 ports and 2 SFP slots, all RJ45 Ports support the PoE st..
R3,951
incl. VAT:R4,544
Add to Cart
Switch DAHUA S3220-16GT-190 Switch type Unmanaged Rack mounting Yes Form factor Desktop 16xRJ-45 ports RJ-45 Ports Type Gigabit Ethernet (10/100/1000) 2xFiber uplink ports quantity Power over Ethernet (PoE) Yes 16xPower over Ethernet (PoE) ports quantity 2xPower over Ethernet 4PPoE (PoE++) ports quantity Total Power over Ethernet (PoE) budget 190 W S3220-16GT-190 Switch DAHUA S3220-16GT-190 Switch type Unmanaged Rack mounting Yes Form factor Desktop 16xRJ-45 ports RJ-45 Ports Type Gigabit Ethernet (10/100/1000) 2xFiber uplink ports quantity Power over Ethernet (PoE) Yes 16xPower over Ethernet (PoE) ports quantity 2xPower over Ethernet 4PPoE (PoE++) ports quantity Total Power over Ethernet (PoE) budget 190 W S3220-16GT-190
✅ In Stock
Brand: DAHUA
R3,953
incl. VAT:R4,546
Add to Cart
UBIQUITI UniFi Switch Ultra 60W/ 8 Port Layer 2 PoE++ input PoE+ output USW-Ultra-60W
✅ In Stock
The Ubiquiti UniFi Switch Ultra 60W is a pivotal addition to any network, designed to deliver both efficiency and reliability. With its stable DC 27 V..
R3,970
incl. VAT:R4,565
Add to Cart