TP-Link Omada 8-Port Gigabit Smart Switch with 4-Port PoE+ – photo 1
TP-Link Omada 8-Port Gigabit Smart Switch with 4-Port PoE+ – photo 2
TP-Link Omada 8-Port Gigabit Smart Switch with 4-Port PoE+ – photo 3
TP-Link Omada 8-Port Gigabit Smart Switch with 4-Port PoE+ – photo 4
TP-Link Omada 8-Port Gigabit Smart Switch with 4-Port PoE+ – photo 5
TP-Link Omada 8-Port Gigabit Smart Switch with 4-Port PoE+ – photo 6
✅ In Stock
TP-LINK

TP-Link Omada 8-Port Gigabit Smart Switch with 4-Port PoE+

R2,943
incl. VAT: R3,384
  • Stock: Backordered - delivers in 10-15 days
  • Brand: TP-LINK
  • Model: SG2008P
  • Weight: 1.29 kg
  • Dimensions: 32 × 24 × 7 cm
  • EAN: 6935364072957
  • Product code: 609338
Backordered goods Delivery in 10–15 working days

Available Options

R2,943 incl. VAT: R3,384
SavePDF

Key features

  • 8× Gigabit ports (4× 802.3at/af-compliant PoE+ ports)
  • 62 W total PoE budget with up to 30 W PoE output per port*
  • Centralized cloud management via the web or the Omada app†
  • Standalone management via web, CLI, SNMP, and RMON
  • Static Routing helps route internal traffic for higher efficiency
  • VLAN, ACL, QoS, and IGMP Snooping
  • Fanless design for silent operation
  • Durable metal casing and desktop/wall mounting design

Description

TP-Link’s brand new Omada smart switches provide huge upgrade comparing with previous versions. The switches can be managed by Omada SDN Controller, which provides professional and reliable one-step solutions. Integrated L2 and L2+ features such as 802.1Q VLAN, QoS, IGMP Snooping and static routing provide cost-effective networking solutions for small and medium-sized businesses without sacrificing enhanced usability and strong performance.

Specifications

Management features
Switch type Managed
Switch layer L2/L2+
Quality of Service (QoS) support Yes
Web-based management Yes
ARP inspection Yes
System event log Yes
MIB support MIB II (RFC1213) Bridge MIB (RFC1493) P/Q-Bridge MIB (RFC2674) Radius Accounting Client MIB (RFC2620) Radius Authentication Client MIB (RFC2618) Remote Ping, Traceroute MIB (RFC2925) Support TP-Link private MIBs RMON MIB(RFC1757, rmon 1,2,3,9)
Ports & interfaces
Basic switching RJ-45 Ethernet ports quantity 8
Basic switching RJ-45 Ethernet ports type Gigabit Ethernet (10/100/1000)
Installed SFP modules quantity 0
Installed SFP+ modules quantity 0
Network
Networking standards IEEE 802.1D, IEEE 802.1Q, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3af, IEEE 802.3at, IEEE 802.3i, IEEE 802.3u, IEEE 802.3x
10G support No
Port mirroring Yes
Flow control support Yes
Link aggregation Yes
Broadcast storm control Yes
Rate limiting Yes
Auto MDI/MDI-X Yes
Spanning tree protocol Yes
Auto-negotiation Yes
VLAN support Yes
Number of VLANs 4094
Data transmission
MAC address table 8000 entries
Switching capacity 16 Gbit/s
Forwarding rate 11.9 Mpps
Number of queues 8
Jumbo frames support Yes
Jumbo frames 9000
Packet buffer memory 4.1 MB
Security
DHCP features DHCP client, DHCP relay, DHCP snooping, DHCPv6 server, DHCPv6 snooping
IGMP snooping Yes
Security algorithms 802.1x RADIUS
MAC address filtering Yes
Authentication MAC-based authentication, Web-based authentication
Authentication type RADIUS
Multicast features
Multicast support Yes
Protocols
Management protocols SNMPv1/v2c/v3
IPv4 & IPv6 features IPv6 Telnet, IPv6 ping, IPv6 tracert
Design
Rack mounting Yes
Product colour Black
LED indicators Yes
Performance
Fanless Yes
Power
Power supply included Yes
Power consumption (max) 77.3 W
Power over Ethernet (PoE)
Power over Ethernet (PoE) Yes
Power over Ethernet plus (PoE+) ports quantity 4
Operational conditions
Operating temperature (T-T) 0 - 40 °C
Storage temperature (T-T) -40 - 70 °C
Operating relative humidity (H-H) 10 - 90%
Storage relative humidity (H-H) 5 - 90%
Heat dissipation 263.6 BTU/h
Weight & dimensions
Width 209 mm
Depth 126 mm
Height 26 mm
Packaging content
Manual Yes
Packaging data
Package type Box
Certificates
Certification CE, FCC, RoHS
NETGEAR GS108EPP Unmanaged Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Desktop/Wall-Mounting Grey
✅ In Stock
Brand: NETGEAR
EASY POE CONTROLSManage PoE prioritization, PoE power limit per port, PoE scheduling and more for advanced control over all PoE-powered devicesGIGABIT..
R2,943
incl. VAT:R3,384
Add to Cart
NETGEAR GS524-300EUS network switch Unmanaged Gigabit Ethernet (10/100/1000) Grey
✅ In Stock
Brand: NETGEAR
Take Gigabit to the Desktop..
R2,943
incl. VAT:R3,384
Add to Cart
TRENDnet Industrial Switch 8 Port Gbit Unman. L2 IP30 Metal
✅ In Stock
Brand: TRENDNET
R2,943
incl. VAT:R3,384
Add to Cart
TP-Link JetStream 8-Port Gigabit Smart Switch
✅ In Stock
Brand: TP-LINK
Realize More Possibilities with OmadaJetStream 8-Port Gigabit Smart SwitchSoftware Defined Networking (SDN) with Cloud AccessOmada’s Software Defined ..
R2,943
incl. VAT:R3,384
Add to Cart
Zyxel GS1915-24E Managed L2 Gigabit Ethernet (10/100/1000) 1U Black Zyxel GS1915-24E Managed L2 Gigabit Ethernet (10/100/1000) 1U Black
✅ In Stock
Brand: ZYXEL
The Zyxel GS1915 Series offers 8/24-port GbE Smart Managed Switches with and without PoE connectivity to small business network. The GS1915 Series sup..
R2,940
incl. VAT:R3,381
Add to Cart
Switch MIKROTIK PoE ports 1 CRS305-1G-4S+IN Switch MIKROTIK PoE ports 1 CRS305-1G-4S+IN
✅ In Stock
Brand: MIKROTIK
The CRS305 is a compact yet very powerful switch, featuring four SFP+ ports, for up to 10 Gbit per port. The device has a 1 Gbit copper ethernet port ..
R2,960
incl. VAT:R3,404
Add to Cart
TP-Link Omada 5-Port Gigabit Smart Switch with 1-Port PoE++ In and 4-Port PoE+ Out
✅ In Stock
Brand: TP-LINK
PoE-Powered PoE Switch forSimplified Outdoor Network DeploymentOmada 5-Port Gigabit Smart Switch with 1-Port PoE++ In and 4-Port PoE+ OutStandard PoE ..
R2,922
incl. VAT:R3,361
Add to Cart
D-Link DGS-1210-10 Managed L2 Gigabit Ethernet (10/100/1000) 1U Black, Grey
✅ In Stock
Brand: D-LINK
The DGS-1210-52 Web Smart switch with advanced management functions including SNMP, Web Management, SmartConsole Utility, and compact command line pro..
R2,968
incl. VAT:R3,413
Add to Cart