Zyxel GS1900-24EP Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black – photo 1
Zyxel GS1900-24EP Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black – photo 2
Zyxel GS1900-24EP Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black – photo 3
Zyxel GS1900-24EP Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black – photo 4
Zyxel GS1900-24EP Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black – photo 5
Out of Stock / Please Enquire ETA
ZYXEL

Zyxel GS1900-24EP Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black

R5,423
incl. VAT: R6,237
  • Stock: Out of Stock / Please Enquire ETA
  • Brand: ZYXEL
  • Model: GS1900-24EP-EU0101F
  • Weight: 1 kg
  • Dimensions: 10 × 10 × 10 cm
  • EAN: 4718937609468
  • Product code: 287260
Please Inquire
R5,423 incl. VAT: R6,237
We will email you when the product is back in stock.
SavePDF

Key features

  • Start up button
  • VLAN
  • QoS
  • Link aggregation

Description

Near silent operation

The GS1900 Series includes both fan-less and built-in smart fan models. The smart fan is designed to automatically adjust speed based on device temperature. You can barely hear the sound while the switch is operating. It is ideal for your office environment.

Intelligent PoE+ powers more devices

PoE models (8HP/10HP/24EP/24HPv2/48HPv2) come with default PoE consumption mode which delivers only the actual power required by your networked devices, reserves the rest and optimizes its power budget. That means a single switch can power more APs, IP cameras and VoIP phones, ensuring a better ROI for your business. All of them support the IEEE 802.3at providing a maximum of 30W per port.

Speedy Gigabit performance—built for SMBs

The GS1900 is a series of switches with full non-blocking bandwidth of up to 1 Gbps per port. An ideal upgrade from an unmanaged switch, it’s a great choice for SMBs that want to enjoy high-speed business network applications at full wired non-blocking speed.

Easy and intuitive management

The Smart Managed GS1900 Series switch feature with web-based interface to manage advanced functions such as VLAN, QoS, IGMP Snooping, Link Aggregation (LAG), IPv6 and DoS prevention easily. Also, the user-friendly wizard helps to walk through setup, configuration and even advanced settings quickly.

Specifications

Management features
Switch type Managed
Switch layer L2
Quality of Service (QoS) support Yes
MIB support RFC 1213 MIB II RFC 2819 RMON (group 1, 2, 3, 9) RFC 1215 generic traps RFC 1493 bridge Zyxel private common MIB
Ports & interfaces
Basic switching RJ-45 Ethernet ports quantity 24
Basic switching RJ-45 Ethernet ports type Gigabit Ethernet (10/100/1000)
Installed SFP modules quantity 0
Installed SFP+ modules quantity 0
Power connector AC-in jack
Network
Networking standards IEEE 802.1D, IEEE 802.1ab, IEEE 802.1af, IEEE 802.1s, IEEE 802.1w, IEEE 802.3at, IEEE 802.3az, IEEE 802.3p, IEEE 802.3u, IEEE 802.3x
10G support No
Cable types supported Cat5, Cat5e
Port mirroring Yes
Full duplex Yes
Flow control support Yes
Link aggregation Yes
Auto MDI/MDI-X Yes
Spanning tree protocol No
Ethernet LAN data rates 10,100,1000 Mbit/s
MAC address auto-learning supported Yes
VLAN support Yes
Virtual LAN features Tagged VLAN, VLAN Identifier ( VLAN ID), Voice VLAN
Data transmission
MAC address table 8000 entries
Switching capacity 48 Gbit/s
Forwarding rate 35.7 Mpps
Store-and-forward Yes
Jumbo frames support Yes
Jumbo frames 9000
Packet buffer memory 0.525 MB
Security
DHCP features DHCP client
IGMP snooping Yes
Security algorithms 802.1x RADIUS
MAC address filtering Yes
Static port security Yes
SSH/SSL support Yes
Password protection Yes
Authentication type HWTACACS+, IEEE 802.1x, RADIUS
Multicast features
Multicast support Yes
Design
Rack mounting Yes
Stackable Yes
Product colour Black
Reset button Yes
Performance
Noise level 26 dB
Power
Power supply included Yes
AC input voltage 100 - 240 V
AC input frequency 50 - 60 Hz
Power consumption (typical) 206.5 W
Power over Ethernet (PoE)
Power over Ethernet (PoE) Yes
Weight & dimensions
Width 330 mm
Depth 330 mm
Height 44 mm
Weight 2.48 kg
Packaging content
Cables included AC
Quick start guide Yes
User guide Yes
Manual Yes
Packaging data
Package type Box
Logistics data
Harmonized System (HS) code 85176990
ALLNET Switch Unmanaged Industrial 3 Port 2.5Gigabit 90W 1x PoE BT 2x SFP 1G-2.5G Switch Fibre Optic ALLNET Switch Unmanaged Industrial 3 Port 2.5Gigabit 90W 1x PoE BT 2x SFP 1G-2.5G Switch Fibre Optic
✅ In Stock
Brand: ALLNET
R5,435
incl. VAT:R6,250
Add to Cart
Planet 8-Port 10/100/1000/2500T + 1-Port 10G SFP+ Multigigabit Ethernet Switch Fanless Design
✅ In Stock
Brand: PLANET
R5,435
incl. VAT:R6,250
Add to Cart
ALLNET Smart Managed Layer 2 Switch 24x GbE 4x SFP+ 19-inch Fanless Switch 128 Gbps
✅ In Stock
Brand: ALLNET
R5,435
incl. VAT:R6,250
Add to Cart
NETGEAR GS316EP-100PES network switch Managed Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black
✅ In Stock
Brand: NETGEAR
The NETGEAR 16-Port PoE+ Gigabit Ethernet Plus Switch delivers essential business networking features and powers PoE+ devices like VoIP phones, IP cam..
R5,435
incl. VAT:R6,250
Add to Cart
TP-Link Omada 24-Port Gigabit L2+ Managed Switch with 4 10GE SFP+ Slots
✅ In Stock
Brand: TP-LINK
TP-Link | Omada L2+ managed switches provide high performance, powerful L2 and L2+ features like static routing, enterprise-level QoS, advanced securi..
R5,445
incl. VAT:R6,262
Add to Cart
ROLINE 21.14.3524 Gigabit Ethernet 10-100-1000 Full Duplex PoE
✅ In Stock
Brand: ROLINE
R5,459
incl. VAT:R6,278
Add to Cart
Cisco Catalyst 1200 Managed L2 Gigabit Ethernet 10-100-1000 Rack-mounting 1U
✅ In Stock
Brand: CISCO
R5,387
incl. VAT:R6,196
Add to Cart
Digitus 24-port Gigabit Switch 19-inch Managed 2 Uplinks Digitus 24-port Gigabit Switch 19-inch Managed 2 Uplinks
✅ In Stock
Brand: DIGITUS
R5,459
incl. VAT:R6,278
Add to Cart