Allied Telesis iGS950/28PS Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Desktop/Wall-Mounting Silver – photo 1
Out of Stock / Please Enquire ETA
ALLIED TELESIS

Allied Telesis iGS950/28PS Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Desktop/Wall-Mounting Silver

R10,018
incl. VAT: R11,520
  • Stock: Out of Stock / Please Enquire ETA
  • Brand: ALLIED TELESIS
  • Model: AT-IGS950/28PS-950
  • Weight: 5.09 kg
  • Dimensions: 51 × 36 × 9 cm
  • EAN: 767035239569
  • Product code: 1050539
Please Inquire
R10,018 incl. VAT: R11,520
We will email you when the product is back in stock.
SavePDF

Key features

  • VLAN
  • Quality of Service Classification
  • IP Multicast Support (IPv4)
  • IEEE 802.3ad Link Aggregation
  • IEEE 802.1x Port-based, MAC-based and Network Access Control

Description

The Allied Telesis iGS950 Series of WebSmart network switches demonstrates the Allied Telesis commitment to environmentally-friendly processes and products, minimizing power consumption through the use of a high efficiency power supply and a low power chipset. Featuring PoE+, iGS950 Series switches at the network edge are the ideal cost-effective solution for small businesses.

Ease of management and high performance

These advanced Allied Telesis WebSmart switches combine the simplicity of unmanaged switches with the performance and reliability of managed switches. This provides a cost-effective, secure and reliable solution for integrated management at the network edge. With user-friendly web-based management, the iGS950 Series is ideal for integrating simple management and security into your network solution.

Power over Ethernet (PoE)

The iGS950/10PS, 20PS, 28PS and 52PS switches are available in PoE+ (IEEE 802.3at), with the capability of delivering up to 30W per port. PoE allows users to connect and power a device using a single Ethernet cable, thus eliminating the need for additional power outlets and simplifying installation. Furthermore, this system is unaffected by any local variance in AC power, offering a standardized power infrastructure.

Specifications

Management features
Switch type Managed
Switch layer L2
Quality of Service (QoS) support Yes
Web-based management Yes
Configuring Location Settings (CLI) Yes
MIB support RFC 1213 MIB-II RFC 1643 Ethernet MIB RFC 1493 Bridge MIB RFC 2131 DHCPv4 server and client Private Enterprise MIB (Allied Telesis provides the spec)
Ports & interfaces
Basic switching RJ-45 Ethernet ports quantity 24
Basic switching RJ-45 Ethernet ports type Gigabit Ethernet (10/100/1000)
Installed SFP modules quantity 0
Installed SFP+ modules quantity 0
Gigabit Ethernet (copper) ports quantity 24
Combo SFP ports quantity 4
Network
Networking standards IEEE 802.1D, IEEE 802.1w, IEEE 802.1s, IEEE 802.1p, IEEE 802.3ad, IEEE 802.1x, IEEE 802.3at
10G support No
Copper ethernet cabling technology 10BASE-T, 100BASE-T, 1000BASE-T
Full duplex Yes
Link aggregation Yes
Ethernet LAN data rates 10,1000,100 Mbit/s
VLAN support Yes
Number of VLANs 256
Optical fiber
Fiber ethernet cabling technology 100BASE-FX, 1000BASE-SX, 1000BASE-LX
Data transmission
MAC address table 8000 entries
Switching capacity 56 Gbit/s
Forwarding rate 41.7 Mpps
Jumbo frames support Yes
Jumbo frames 10000
Packet buffer memory 0.512 MB
Security
DHCP features DHCP client
Access Control List (ACL) Yes
Access Control List (ACL) IPv4 entries 256
IGMP snooping Yes
SSH/SSL support Yes
Multicast features
Multicast support Yes
Design
Rack mounting Yes
Form factor Desktop/Wall-Mounting
Product colour Silver
Reset button Yes
LED indicators Yes
Wall mountable Yes
Performance
Memory type DRAM
Internal memory 256 MB
Flash memory 32 MB
Noise level 51.7 dB
Telnet Yes
Fanless No
Power
Power source AC
AC input voltage 100 - 240 V
AC input frequency 50/60 Hz
Input current 7 A
Power consumption (typical) 29.8 W
Power consumption (max) 446.1 W
Power plug type Type F
Power over Ethernet (PoE)
Power over Ethernet (PoE) Yes
Power over Ethernet (PoE) type supported PoE+
Power over Ethernet (PoE) ports quantity 24
Power over Ethernet plus (PoE+) ports quantity 12
Power over Ethernet (PoE) power per port 30 W
Total Power over Ethernet (PoE) budget 370 W
Other features
Size (imperial) 48.3 cm (19")
Operational conditions
Operating temperature (T-T) -5 - 50 °C
Storage temperature (T-T) -25 - 70 °C
Operating relative humidity (H-H) 5 - 90%
Storage relative humidity (H-H) 5 - 95%
Operating altitude 0 - 3000 m
Heat dissipation 1521.9 BTU/h
Weight & dimensions
Width 440 mm
Depth 250 mm
Height 44 mm
Weight 3.92 kg
Packaging content
Cables included Power
Rack mount kit Yes
Packaging data
Mounting brackets included Yes
Rubber feet Yes
Screws included Yes
Sustainability
Doesn't contain Lead, Mercury, Cadmium
Certificates
Compliance certificates Trade Agreements Act (TAA), CE, UKCA, Federal Communications Commission (FCC), UL, TÜV mark, RoHS
LevelOne GEL-5271 network switch Managed L2+ Gigabit Ethernet (10/100/1000) 1U Black
✅ In Stock
Brand: LEVELONE
The LevelOne GEL-5271 is an intelligent 52-Port L2 plus managed gigabit switch with 48 RJ45 ports and 4 SFP fiber slots, designed for enterprise or la..
R10,031
incl. VAT:R11,535
Add to Cart
TP-Link Omada 24-Port 2.5GBASE-T L2+ Managed Switch with 4 10GE SFP+ Slots
✅ In Stock
Brand: TP-LINK
TP-Link | Omada L2+ managed switches provide high performance, powerful L2 and L2+ features like static routing, enterprise-level QoS, advanced securi..
R10,031
incl. VAT:R11,535
Add to Cart
StarTech.com 4 Port HDMI KVM Switch - Single Monitor 4K 60Hz Ultra HD HDR - Desktop HDMI 2.0 KVM Switch with 2 Port USB 3.0 Hub (5Gbps) and 4x USB 2.0 HID, Audio - Hotkey Switching - TAA
✅ In Stock
Brand: STARTECH.COM
KVM with USB | TAA Compliant | USB 3.0 Hub | HDMI 2.0 | Digital & Analog AudioThis 4 port KVM switch combines 4K (60Hz) digital display capabilities w..
R10,031
incl. VAT:R11,535
Add to Cart
StarTech.com 8 Port Rackmount USB VGA KVM Switch w/ Audio (Audio Cables Included) - TAA
✅ In Stock
Brand: STARTECH
Control up to 8 VGA and USB computers from a single keyboard, mouse and monitorThe SV831DUSBAU 8 Port Rack Mount USB VGA KVM Switch (with Audio Cables..
R10,050
incl. VAT:R11,558
Add to Cart
TP-Link Omada 8-Port 2.5GBASE-T and 2-Port 10GE SFP+ L2+ Managed Switch with 8-Port PoE+
✅ In Stock
Brand: TP-LINK
Ultrafast 2.5G PoE+ Managed Switch with 10G Uplink for a Complete Omada NetworkSG3210XHP-M22.5G PoE+ Ports for WiFi 68× 2.5 Gbps Ports Uplock the Full..
R9,984
incl. VAT:R11,481
Add to Cart
TP-Link Omada 8-Port 2.5GBASE-T and 2-Port 10GE SFP+ L2+ Managed Switch with 8-Port PoE+
✅ In Stock
Brand: TP-LINK
Ultrafast 2.5G PoE+ Managed Switch with 10G Uplink for a Complete Omada NetworkSG3210XHP-M22.5G PoE+ Ports for WiFi 68× 2.5 Gbps Ports Uplock the Full..
R9,983
incl. VAT:R11,481
Add to Cart
Cisco CBS220-48T-4G Managed L2 Gigabit Ethernet 10-100-1000 Rack-mounting 1U
✅ In Stock
Brand: CISCO
R10,054
incl. VAT:R11,562
Add to Cart
Mikredik CRS317-1G-16S+RM
✅ In Stock
Brand: MIKROTIK
R9,960
incl. VAT:R11,454