Allied Telesis AT-FS750/28PS-50 Managed Fast Ethernet (10/100) Power over Ethernet (PoE) 1U Grey – photo 1
Out of Stock / Please Enquire ETA
ALLIED TELESIS

Allied Telesis AT-FS750/28PS-50 Managed Fast Ethernet (10/100) Power over Ethernet (PoE) 1U Grey

R10,871
incl. VAT: R12,502
  • Stock: Out of Stock / Please Enquire ETA
  • Brand: ALLIED TELESIS
  • Model: AT-FS750/28PS-50
  • Weight: 4.22 kg
  • Dimensions: 55 × 35 × 10 cm
  • EAN: 767035203997
  • Product code: 1019517
Please Inquire
R10,871 incl. VAT: R12,502
We will email you when the product is back in stock.
SavePDF

Key features

  • Managed Web-based management
  • Quality of Service (QoS) support
  • Basic switching RJ-45 Ethernet ports quantity: 24
  • MAC address table: 8000 entries Switching capacity: 12.8 Gbit/s
  • Access Control List (ACL)
  • 1U Rack mounting
  • AC Power over Ethernet (PoE)

Description

The Allied Telesis AT-FS750/28PS WebSmart network switch features PoE+ for connectivity with security cameras, VoIP phones, RFID readers, and wireless access points. The FS750PS Series is a cost effective solution for SMB, retail stores, and at the edge of the network.

Specifications

Management features
Switch type Managed
Quality of Service (QoS) support Yes
Web-based management Yes
System event log Yes
MIB support RFC 1213 MIB-II, RFC 1643 Ethernet MIB, RFC 1493 Bridge MIB, RFC 2131 DHCP client, Private Enterprise MIB
Ports & interfaces
Basic switching RJ-45 Ethernet ports quantity 24
Basic switching RJ-45 Ethernet ports type Fast Ethernet (10/100)
Installed SFP modules quantity 0
Installed SFP+ modules quantity 0
Fast Ethernet (copper) ports quantity 24
Gigabit Ethernet (copper) ports quantity 2
Combo SFP ports quantity 2
Network
Networking standards IEEE 802.11d, IEEE 802.1Q, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3ad, IEEE 802.3af, IEEE 802.3at, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z
10G support No
Port mirroring Yes
Flow control support Yes
Link aggregation Yes
Broadcast storm control Yes
Rate limiting Yes
Spanning tree protocol Yes
Head-of-line (HOL) blocking Yes
VLAN support Yes
Virtual LAN features Tagged VLAN, Port-based VLAN
Number of VLANs 256
Data transmission
MAC address table 8000 entries
Switching capacity 12.8 Gbit/s
Throughput 9.5 Mpps
Number of queues 4
Jumbo frames support Yes
Packet forwarding rate (1 Gbps) 1488000 pps
Packet forwarding rate (100 Mbps) 148800 pps
Packet forwarding rate (10 Mbps) 14880 pps
Packet buffer memory 4.1 MB
Security
DHCP features DHCP client
Access Control List (ACL) Yes
IGMP snooping Yes
MAC address filtering Yes
Authentication MAC-based authentication
Multicast features
Multicast support Yes
Number of multicast groups filtered 256
Design
Rack mounting Yes
Form factor 1U
Product colour Grey
Power
Power source AC
AC input voltage 100 - 240 V
AC input frequency 50 - 60 Hz
Power consumption (max) 241 W
Power over Ethernet (PoE)
Power over Ethernet (PoE) Yes
Power over Ethernet (PoE) ports quantity 24
Power over Ethernet plus (PoE+) ports quantity 4
Total Power over Ethernet (PoE) budget 193 W
Operational conditions
Operating temperature (T-T) 0 - 40 °C
Storage temperature (T-T) 5 - 90 °C
Operating relative humidity (H-H) -25 - 70%
Storage relative humidity (H-H) 5 - 95%
Weight & dimensions
Width 410 mm
Depth 210 mm
Height 44 mm
Weight 5 kg
Packaging content
Cables included AC
Logistics data
Harmonized System (HS) code 85176990
HPE Instant on 1960 28-Port Switch 24x Gigabit LAN 2x SFP+ 2x 10
✅ In Stock
Brand: HP ENTERPRISE
R10,896
incl. VAT:R12,531
Add to Cart
AXIS T8508 POE+ NETWORK SWITCH - IN
✅ In Stock
Brand: AXIS
R10,910
incl. VAT:R12,546
Add to Cart
Cisco Catalyst 1300-16T-2G Switch L3 Managed
✅ In Stock
Brand: CISCO
R10,826
incl. VAT:R12,450
Add to Cart
Ubiquiti Dream Machine Professional 3.5 Ubiquiti Dream Machine Professional 3.5
✅ In Stock
Brand: UBIQUITI
R10,826
incl. VAT:R12,450
Add to Cart
ALLNET Switch Smart Managed Layer2 54 Port 48x 1 GbE 6x SFP+ 19 ALLNET Switch Smart Managed Layer2 54 Port 48x 1 GbE 6x SFP+ 19
✅ In Stock
Brand: ALLNET
R10,943
incl. VAT:R12,585
Add to Cart
LevelOne 26-Port Fast Ethernet PoE Switch, 24 PoE Outputs, 2 x Gigabit RJ45, 150W
✅ In Stock
Brand: LEVELONE
The LevelOne FGP-2601 series are unmanaged PoE switches with 24 RJ45 PoE ports. The switches are IEEE 802.3af/at compliant, providing power and data o..
R10,943
incl. VAT:R12,585
Add to Cart
LevelOne GEP-2652 network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Grey
✅ In Stock
Brand: LEVELONE
The LevelOne GEP-2652, the latest web smart generation, is equipped with 24 PoE ports and 2 Gigabit SFP ports. It offers powerful Layer2 capabilities,..
R10,943
incl. VAT:R12,585
Add to Cart
Grandstream Networks UCM6304 IP Centrex Hosted-virtual IP 2000 Users Gigabit Ethernet Grandstream Networks UCM6304 IP Centrex Hosted-virtual IP 2000 Users Gigabit Ethernet
✅ In Stock
R10,967
incl. VAT:R12,612
Add to Cart